当前位置 博文首页 > baymax__dabai的博客:POJ 2586 Y2K Accounting Bug(贪心)

    baymax__dabai的博客:POJ 2586 Y2K Accounting Bug(贪心)

    作者:[db:作者] 时间:2021-08-02 12:36

    Y2K Accounting Bug

    Time Limit: 1000MS?Memory Limit: 65536K
    Total Submissions: 18142?Accepted: 9192

    Description

    Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
    All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

    Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

    Input

    Input is a sequence of lines, each containing two positive integers s and d.

    Output

    For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

    Sample Input

    59 237
    375 743
    200000 849694
    2500000 8000000

    Sample Output

    116
    28
    300612
    Deficit

    题目大意:(这道题目更像是一道翻译题我觉得)

    MS公司在1999年的每个月的盈利和亏损都是一个定数,要么盈利s,要么亏损d。

    他们公司每五个连续的月会发布一个盈亏报表,并且ACM知道八个这样的报表里(即1-5,2-6,3-7...8-12),任意一个都是亏损的。

    求满足上面条件的同时哪些月亏空,哪些月盈利可以使盈利额最大,如果不可能盈利则输出“Deficit”。

    思路:即在满足条件的情况下,让盈利的月最多

    AC代码:

    #include <iostream>
    #include <stdio.h>
    #include <math.h>
    #include <algorithm>
    using namespace std;
    int main()
    {
    //    freopen("in.txt","r",stdin);
        long long s,d;
        long long temp;
        while(~scanf("%lld%lld",&s,&d))
        {
            if(d>4*s)//盈亏情况为 ssssdssssdss
                temp=10*s-2*d;
            else if(d<=4*s&&2*d>3*s)//sssddsssddss
                temp=8*s-4*d;
            else if(2*d<=3*s&&3*d>2*s)//ssdddssdddss
                temp=6*s-6*d;
            else if(3*d<=2*s&&4*d>s)//sddddsddddsd
                temp=3*s-9*d;
            else//dddddddddddd
                temp=-1;
            if(temp>=0)
                printf("%lld\n",temp);
            else
                printf("Deficit\n");
        }
        return 0;
    
    }
    
    

    如有需要改进的地方,还请大佬们指教!

    cs